CentOSのRPMでOSのバージョン間違い

Pocket

新しいサーバをZABBIXで監視に追加するためにZABBIXのリポジトリインストール用のRPMをインストールしようと思ったら、見慣れないエラーが出てインストールできなかった。

ZABBIX-JPのyumリポジトリ利用方法 | ZABBIX-JP

# wget http://repo.zabbix.jp/relatedpkgs/rhel6/i386/zabbix-jp-release-6-6.noarch.rpm
# rpm -ivh zabbix-jp-release-6-6.noarch.rpm
警告: /var/tmp/rpm-xfer.eXQBuk: ヘッダ V4 DSA signature: NOKEY, key ID f32904ff
エラー: 依存性の欠如:
	rpmlib(FileDigests) <= 4.6.0-1 は zabbix-jp-release-6-6.noarch に必要とされています
	rpmlib(PayloadIsXz) <= 5.2-1 は zabbix-jp-release-6-6.noarch に必要とされています

rpmlibというパッケージがインストールされて無いことが原因かと思たののでyum searchで調べてみたけども該当するようなパッケージは見つからない。
ググって調べてみてもなんだか要領を得ない。

なんだろうと思って、ふとOSのバージョンを確認したら。

# cat /etc/redhat-release
CentOS release 5.8 (Final)

CentOS5系だった・・・
新しく導入したサーバだからCentOS6系だと思い込んで、CentOS6系用のRPMをインストールしようとしていた。
ただの思い込みだったわけだ。

# rpm -ivh http://repo.zabbix.jp/relatedpkgs/rhel5/i386/zabbix-jp-release-5-6.noarch.rpm

CentOS5系用のパッケージをインストールして解決。

自分で調達したものではなかったので気づかなかったという。

rpmコマンドのエラーではOSのバージョンが違うとかは特に出ないようになってるんだな。
似たようなエラーが出た場合はRPMパッケージの対応OSが合っているか確認してみよう。

関連記事

Pocket

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です