Ruby 1.9.1って安定版なの?

Pocket

Rubyをいつものごとくダウンロードしようとして

ふと文章にひっかかった。

Rubyダウンロード

  • 最新の安定版であるruby 1.9.1-p0[tar.bz2|tar.gz|zip]が各ミラーサイトから入手できます。
  • 前世代の安定版であるruby 1.8.7-p72[tar.bz2|tar.gz|zip]も各ミラーサイトから入手できます。

あれ?1.8系が前世代で1.9系が最新の安定版?

もちろん.1.8系の最新版をダウンロードしようとしたのだけれど。。。

そっか、バージョンの管理のしかたが変わったんだっけか。

1.9.1は安定版なんだ。ruby-listとってるのに最近読んでないな。

Ruby 1.9.1をリリースしました。これは1.9系統初の安定版リリースです。
Ruby 1.9はRubyの新しい系統です。近代的に、高速に、文法も明確に、多言語化
され、多くの改善がなされました。Ruby 1.8系統は2003年以来利用され、多くの
素晴らしい製品を生み出しました。本日、1.9の歴史が始まります。

なお、Ruby 1.8はまだ継続します。1.8.8は今年くらいにはリリースされるで
しょう。

ほんまや。1/31にリリースされとる。

といっても自分が使っているレベルではあんま変わんないかも。

でも、入れてつかってみたいな。うーん、どの環境も運用でつかっちゃってるし。。

関連記事

Pocket

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です